SharePoint By Yagya Shree

“File Not Found” error message accessing main page after enabling custom feature on site collection

leave a comment »

ISSUE:

——–

àAfter enabling the feature customer was unable to access the main page of the site and got error message “File Not Found”

àYou are facing the same issue when he browse the site actions–site settings, “Master Pages” & “Web Parts”
àYou are able to browse the top level site collection http://sps03.shorturl.com/ main page without any error message

àYou are also able to browse “Sites & Workspaces” beneath the http://sps03.shorturl.com/sites/yagyashree
àYou are using OOB Master Page. A summary of the solution is detailed below.

 

 Cause

——–

à Users have tried to enable a custom feature on this site collection

 

Resolution

————-

à Open the SharePoint site http://sps03.shorturl.com/sites/yagyashree in SharePoint Designer 2007
à Opened the subsite under this site
à Copy the default.master from the subsite

à Renamed the original default.master to default.old

à Paste the copy from subsite

à Right Click on new default.master and choose “Make this as new default.master

à Save the changes

à Open the site and it should be working fine
àCheck the site actions–site settings and check the “master pages” & “web parts”, they should be coming up fine

Advertisements

Written by Yagyashree

April 8, 2009 at 12:09 am

Posted in sharepoint

Tagged with , , , , , , , , , , , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: