SharePoint By Yagya Shree

Error: An unexpected error occurred while connecting to the report server. Verify that the report server is available and configured for SharePoint integrated mode.

with one comment

ISSUE:
======
–>You have a SharePoint site http://sps.sharepoint.com/trend and a reports library named “Interactive Reports” http://sps.sharepoint.com/trend/Interactive%20Reports/Forms/AllItems.aspx

–>Once you click on one of the reports and go to “Manage Data Sources”, you get following error message

“An unexpected error occurred while connecting to the report server. Verify that the report server is available and configured for SharePoint integrated mode.”. A summary of the solution is detailed below.
1. Symptom
==========

–>You have a SharePoint site http://sps.sharepoint.com/trend and a reports library named “Interactive Reports” http://sps.sharepoint.com/trend/Interactive%20Reports/Forms/AllItems.aspx

–>Once you click on one of the reports and go to “Manage Data Sources”, you get following error message

“An unexpected error occurred while connecting to the report server. Verify that the report server is available and configured for SharePoint integrated mode.”.

2. Cause
========

–>The issue arises because you were accessing the site with Host header http://sps.sharepoint.com/trend instead of default server name

3. Resolution

 Disable the authentication loopback check
=========================================
–>Went Start, click Run, type regedit, and then click OK.
–>Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
–>Right-click Lsa, point to New, and then click DWORD Value.
–>Type DisableLoopbackCheck, and then press ENTER.
–>Right-click DisableLoopbackCheck, and then click Modify.
–>In the Value data box, type 1, and then click OK.
–>Exit Registry Editor.

–>After disabling the check we opened the site and check the issue, it was not occurring any more

4. More Information
===================

You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or IIS 6

http://support.microsoft.com/?id=896861

Error message when you try to access a server locally by using its FQDN or its CNAME alias after you install Windows Server 2003 Service Pack 1: “Access denied” or “No network provider accepted the given network path”

http://support.microsoft.com/kb/926642/

Advertisements

Written by Yagyashree

April 18, 2009 at 12:41 am

One Response

Subscribe to comments with RSS.

  1. champion.

    Sardar M Guljar

    August 18, 2011 at 7:32 am


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: